Wireless LAN FAQ

Di manakah sebaiknya saya menempatkan Base Station?

Base station biasanya diletakkan di tempat yang tinggi, yang memungkinkan dapat terjangkau dari pelanggan. Bisa berupa rooftop dari gedung tinggi, ataupun tower.

Perangkat apa saja yang dibutuhkan di Base Station?

Pada dasarnya, perangkat wireless di base station di bagi dua, yaitu perangkat point to point sebagai backhaul, dan perangkat lainnya untuk melayani pelanggan. Perangkat backhaul tidak dibutuhkan jika Anda memiliki akses internet ke BTS via kabel ataupun media lain. Untuk access pointnya sendiri, biasanya menggunakan antenna yang dapat melayani area yang cukup lebar. Bisa berupa omnidirectional antenna, ataupun antenna sectoral. Omnidirectional antenna dapat menjangkau 360 derajat, sedangkan antenna sectoral hanya dapat menjangkau 90 hingga 120 derajat, sehingga dibutuhkan 3 hingga 4 antenna, termasuk juga access pointnya.

Berapa client yang dapat terkoneksi ke base station?

Secara teori, perangkat wireless Mikrotik dapat melayani 2007 client. Namun, bagaimanapun juga, performance nya tergantung pada kehandalan sistem dan kondisi sekitar. Jumlah ini sangat regantung pada penggunaan setiap client, dan berapa jumlah komputer yang terkoneksi di belakang sebuah AP Client. Jumlah yang pernah dicapai pada penggunaan normal adalah 100 client.

Berapakah jarak terjauh antara BTS dan lokasi client?

Jarak terjauh akan tergantung pada daya antena, loss pada kabel antenna, kekuatan pancar radio, sensifitas radio, dan tingkat inteferensi dari radio lain yang menggunakan frekuensi yang sama.
Dengan frekuensi 2,4 GHz, biasanya jarak terjauh yang bisa dicapai adalah 12 kilometer, sedangkan dengan frekuensi 5 GHz, dengan menggunakan antenna solid disc 30db, bisa dicapai jarak 28 km. Lebar bandwidth yang bisa dicapai adalah sekitar 10 mbps dengan uji coba bandwidth test.

Dapatkah saya menggunakan amplifier untuk memperjauh jangkauan ?

Secara teknis, bisa. Namun, perhatikan regulasi yang berlaku. Penggunaan amplifier dapat digunakan untuk mengkompensasikan loss yang terjadi akibat penggunaan kabel antenna yang panjang.

Apakah antara BTS dan client harus benar-benar bebas halangan (Line of sight) ?

Ya. Kondisi line of sight mutlak dibutuhkan. Juga perhatikan freznel zone yang dibutuhkan.

Apakah yang dimaksud dengan fresnel zone?

Freznel Zone adalah area di sekitar garis lurus antar alat yang digunakan untuk rambatan gelombang. Area ini juga harus bebas dari gangguan, atau kekuatan signal akan menurun. Sebagai contoh, pada link berjarak 16 km, dengan frekuensi 5,8 GHz, besarnya lingkaran freznel zone di tengah-tengah kedua alat adalah lingkaran dengan radius 8,7 meter, dan 13,6 meter untuk frekuensi 2,4 GHz.

Dapatkah saya melakukan bridge saat menggunakan produk wireless Mikrotik?

Ya. Jika Anda menggunakan Access Point Mikrotik dan client merk lainnya, yang perlu Anda lakukan adalah memasukkan interface wlan pada mikrotik ke interface bridge, demikian juga dengan ethernetnya. Sedangkan bila menggunakan wireless client Mikrotik, Anda bisa melakukan bridge dengan menggunakan teknik EoIP atau menggunakan WDS Wireless. Simak manual penggunaan untuk lebih jelasnya.

Penggunaan IPSec untuk Abacus

/ ip ipsec policy
add src-address=[your ip address]/32:any dst-address=10.10.1.0/24:any
protocol=all action=encrypt level=require ipsec-protocols=esp tunnel=yes
sa-src-address=[ip router] sa-dst-address=203.130.231.5
proposal=abacus manual-sa=none dont-fragment=clear disabled=no

/ ip ipsec peer
add address=203.130.231.5/32:0 secret=”[secret key nya di sini]”
generate-policy=yes
exchange-mode=main send-initial-contact=yes proposal-check=obey
hash-algorithm=md5 enc-algorithm=des dh-group=modp768 lifetime=1d
lifebytes=0 disabled=no

/ ip ipsec proposal
add name=”abacus” auth-algorithms=md5 enc-algorithms=des lifetime=1d
lifebytes=0 pfs-group=none disabled=no

Queue dengan SRC-NAT dan WEB-PROXY

Pada penggunaan queue (bandwidth limiter), penentuan CHAIN pada MENGLE sangat menentukan jalannya sebuah rule. Jika kita memasang SRC-NAT dan WEB-PROXY pada mesin yang sama, sering kali agak sulit untuk membuat rule QUEUE yang sempurna. Penjelasan detail mengenai pemilihan CHAIN, dapat dilihat pada manual Mikrotik di sini.

Percobaan yang dilakukan menggunakan sebuah PC dengan Mikrotik RouterOS versi 2.9.28. Pada mesin tersebut, digunakan 2 buah interface, satu untuk gateway yang dinamai PUBLIC dan satu lagi untuk jaringan lokal yang dinamai LAN.

[admin@instaler] > in pr
Flags: X - disabled, D - dynamic, R - running 
 #    NAME       TYPE    RX-RATE    TX-RATE    MTU  
 0  R public     ether   0          0          1500 
 1  R lan        wlan    0          0          1500

Dan berikut ini adalah IP Address yang digunakan. Subnet 192.168.0.0/24 adalah subnet gateway untuk mesin ini.

[admin@instaler] > ip ad pr
Flags: X - disabled, I - invalid, D - dynamic 
 #  ADDRESS           NETWORK      BROADCAST      INTERFACE
 0  192.168.0.217/24  192.168.0.0  192.168.0.255  public   
 1  172.21.1.1/24     172.21.1.0   172.21.1.255   lan

Fitur web-proxy dengan transparan juga diaktifkan.

 [admin@instaler] > ip web-proxy pr
                 enabled: yes
             src-address: 0.0.0.0
                    port: 3128
                hostname: "proxy"
       transparent-proxy: yes
            parent-proxy: 0.0.0.0:0
     cache-administrator: "webmaster"
         max-object-size: 4096KiB
             cache-drive: system
          max-cache-size: none
      max-ram-cache-size: unlimited
                  status: running
      reserved-for-cache: 0KiB
  reserved-for-ram-cache: 154624KiB

Fungsi MASQUERADE diaktifkan, juga satu buah rule REDIRECTING untuk membelokkan traffic HTTP menuju ke WEB-PROXY

[admin@instaler] ip firewall nat> pr
Flags: X - disabled, I - invalid, D - dynamic 
 0   chain=srcnat out-interface=public 
     src-address=172.21.1.0/24 action=masquerade 
 1   chain=dstnat in-interface=lan src-address=172.21.1.0/24 
     protocol=tcp dst-port=80 action=redirect to-ports=3128

Berikut ini adalah langkah terpenting dalam proses ini, yaitu pembuatan MANGLE. Kita akan membutuhkan 2 buah PACKET-MARK. Satu untuk paket data upstream, yang pada contoh ini kita sebut test-up. Dan satu lagi untuk paket data downstream, yang pada contoh ini kita sebut test-down.

Untuk paket data upstream, proses pembuatan manglenya cukup sederhana. Kita bisa langsung melakukannya dengan 1 buah rule, cukup dengan menggunakan parameter SRC-ADDRESS dan IN-INTERFACE. Di sini kita menggunakan chain prerouting. Paket data untuk upstream ini kita namai test-up.

Namun, untuk paket data downstream, kita membutuhkan beberapa buah rule. Karena kita menggunakan translasi IP/masquerade, kita membutuhkan Connection Mark. Pada contoh ini, kita namai test-conn.

Kemudian, kita harus membuat juga 2 buah rule. Rule yang pertama, untuk paket data downstream non HTTP yang langsung dari internet (tidak melewati proxy). Kita menggunakan chain forward, karena data mengalir melalui router.

Rule yang kedua, untuk paket data yang berasal dari WEB-PROXY. Kita menggunakan chain output, karena arus data berasal dari aplikasi internal di dalam router ke mesin di luar router.

Paket data untuk downstream pada kedua rule ini kita namai test-down.

Jangan lupa, parameter passthrough hanya diaktifkan untuk connection mark saja.

[admin@instaler] > ip firewall mangle print
Flags: X - disabled, I - invalid, D - dynamic 
 0   ;;; UP TRAFFIC
     chain=prerouting in-interface=lan 
     src-address=172.21.1.0/24 action=mark-packet 
     new-packet-mark=test-up passthrough=no 

 1   ;;; CONN-MARK
     chain=forward src-address=172.21.1.0/24 
     action=mark-connection 
     new-connection-mark=test-conn passthrough=yes 

 2   ;;; DOWN-DIRECT CONNECTION
     chain=forward in-interface=public 
     connection-mark=test-conn action=mark-packet 
     new-packet-mark=test-down passthrough=no 

 3   ;;; DOWN-VIA PROXY
     chain=output out-interface=lan 
     dst-address=172.21.1.0/24 action=mark-packet 
     new-packet-mark=test-down passthrough=no

Untuk tahap terakhir, tinggal mengkonfigurasi queue. Di sini kita menggunakan queue tree. Satu buah rule untuk data dowstream, dan satu lagi untuk upstream. Yang penting di sini, adalah pemilihan parent. Untuk downstream, kita menggunakan parent lan, sesuai dengan interface yang mengarah ke jaringan lokal, dan untuk upstream, kita menggunakan parent global-in.

[admin@instaler] > queue tree pr
Flags: X - disabled, I - invalid 
 0   name="downstream" parent=lan packet-mark=test-down 
     limit-at=32000 queue=default priority=8 
     max-limit=32000 burst-limit=0 
     burst-threshold=0 burst-time=0s 

 1   name="upstream" parent=global-in 
     packet-mark=test-up limit-at=32000 
     queue=default priority=8 
     max-limit=32000 burst-limit=0 
     burst-threshold=0 burst-time=0s

Variasi lainnya, untuk bandwidth management, dimungkinkan juga kita menggunakan tipe queue PCQ, yang bisa secara otomatis membagi trafik per client.

Load Balance menggunakan Metode PCC

Load balance pada mikrotik adalah teknik untuk mendistribusikan beban trafik pada dua atau lebih jalur koneksi secara seimbang, agar trafik dapat berjalan optimal, memaksimalkan throughput, memperkecil waktu tanggap dan menghindari overload pada salah satu jalur koneksi.

Selama ini banyak dari kita yang beranggapan salah, bahwa dengan menggunakan loadbalance dua jalur koneksi , maka besar bandwidth yang akan kita dapatkan menjadi dua kali lipat dari bandwidth sebelum menggunakan loadbalance (akumulasi dari kedua bandwidth tersebut). Hal ini perlu kita perjelas dahulu, bahwa loadbalance tidak akan menambah besar bandwidth yang kita peroleh, tetapi hanya bertugas untuk membagi trafik dari kedua bandwidth tersebut agar dapat terpakai secara seimbang.

Dengan artikel ini, kita akan membuktikan bahwa dalam penggunaan loadbalancing tidak seperti rumus matematika 512 + 256 = 768, akan tetapi 512 + 256 = 512 + 256, atau 512 + 256 = 256 + 256 + 256.

Pada artikel ini kami menggunakan RB433UAH dengan kondisi sebagai berikut :
1.    Ether1 dan Ether2 terhubung pada ISP yang berbeda dengan besar bandwdith yang berbeda. ISP1 sebesar 512kbps dan ISP2 sebesar 256kbps.
2.    Kita akan menggunakan web-proxy internal dan menggunakan openDNS.
3.    Mikrotik RouterOS anda menggunakan versi 4.5  karena fitur PCC mulai dikenal pada versi 3.24.

Jika pada kondisi diatas berbeda dengan kondisi jaringan ditempat anda, maka konfigurasi yang akan kita jabarkan disini harus anda sesuaikan dengan konfigurasi untuk jaringan ditempat anda.

Konfigurasi Dasar

Berikut ini adalah Topologi Jaringan dan IP address yang akan kita gunakan

 

/ip address
add address=192.168.101.2/30 interface=ether1
add address=192.168.102.2/30 interface=ether2
add address=10.10.10.1/24 interface=wlan2
/ip dns
set allow-remote-requests=yes primary-dns=208.67.222.222 secondary-dns=208.67.220.220

Untuk koneksi client, kita menggunakan koneksi wireless pada wlan2 dengan range IP client 10.10.10.2 s/d 10.10.10.254 netmask 255.255.255.0, dimana IP 10.10.10.1 yang dipasangkan pada wlan2 berfungsi sebagai gateway dan dns server dari client. Jika anda menggunakan DNS dari salah satu isp anda, maka akan ada tambahan mangle yang akan kami berikan tanda tebal

Setelah pengkonfigurasian IP dan DNS sudah benar, kita harus memasangkan default route ke masing-masing IP gateway ISP kita agar router meneruskan semua trafik yang tidak terhubung padanya ke gateway tersebut. Disini kita menggunakan fitur check-gateway berguna jika salah satu gateway kita putus, maka koneksi akan dibelokkan ke gateway lainnya.

/ip route
add dst-address=0.0.0.0/0 gateway=192.168.101.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.102.1 distance=2 check-gateway=ping

Untuk pengaturan Access Point sehingga PC client dapat terhubung dengan wireless kita, kita menggunakan perintah

/interface wireless
set wlan2 mode=ap-bridge band=2.4ghz-b/g ssid=Mikrotik disabled=no

Agar pc client dapat melakukan koneksi ke internet, kita juga harus merubah IP privat client ke IP publik yang ada di interface publik kita yaitu ether1 dan ether2.

/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1
add action=masquerade chain=srcnat out-interface=ether2

Sampai langkah ini, router dan pc client sudah dapat melakukan koneksi internet. Lakukan ping baik dari router ataupun pc client ke internet. Jika belum berhasil, cek sekali lagi konfigurasi anda.
Webproxy Internal

Pada routerboard tertentu, seperti RB450G, RB433AH, RB433UAH, RB800 dan RB1100 mempunyai expansion slot (USB, MicroSD, CompactFlash) untuk storage tambahan. Pada contoh berikut, kita akan menggunakan usb flashdisk yang dipasangkan pada slot USB. Untuk pertama kali pemasangan, storage tambahan ini akan terbaca statusnya invalid di /system store. Agar dapat digunakan sebagai media penyimpan cache, maka storage harus diformat dahulu dan diaktifkan Nantinya kita tinggal mengaktifkan webproxy dan set cache-on-disk=yes untuk menggunakan media storage kita. Jangan lupa untuk membelokkan trafik HTTP (tcp port 80) kedalam webproxy kita.

/store disk format-drive usb1
/store
add disk=usb1 name=cache-usb type=web-proxy
activate cache-usb

/ip proxy
set cache-on-disk=yes enabled=yes max-cache-size=200000KiB port=8080

/ip firewall nat
add chain=dstnat protocol=tcp dst-port=80 in-interface=wlan2 action=redirect to-ports=8080

Pengaturan Mangle

Pada loadbalancing kali ini kita akan menggunakan fitur yang disebut PCC (Per Connection Classifier). Dengan PCC kita bisa mengelompokan trafik koneksi yang melalui atau keluar masuk router menjadi beberapa kelompok. Pengelompokan ini bisa dibedakan berdasarkan src-address, dst-address, src-port dan atau dst-port. Router akan mengingat-ingat jalur gateway yang dilewati diawal trafik koneksi, sehingga pada paket-paket selanjutnya yang masih berkaitan dengan koneksi awalnya akan dilewatkan  pada jalur gateway yang sama juga. Kelebihan dari PCC ini yang menjawab banyaknya keluhan sering putusnya koneksi pada teknik loadbalancing lainnya sebelum adanya PCC karena perpindahan gateway..
Sebelum membuat mangle loadbalance, untuk mencegah terjadinya loop routing pada trafik, maka semua trafik client yang menuju network yang terhubung langsung dengan router, harus kita bypass dari loadbalancing. Kita bisa membuat daftar IP yang masih dalam satu network router dan  memasang mangle pertama kali sebagai berikut

/ip firewall address-list
add address=192.168.101.0/30 list=lokal
add address=192.168.102.0/30 list=lokal
add address=10.10.10.0/24 list=lokal

/ip firewall mangle
add action=accept chain=prerouting dst-address-list=lokal in-interface=wlan2 comment=”trafik lokal”
add action=accept chain=output dst-address-list=lokal

Pada kasus tertentu, trafik pertama bisa berasal dari Internet, seperti penggunaan remote winbox atau telnet dari internet dan sebagainya, oleh karena itu kita juga memerlukan mark-connection untuk menandai trafik tersebut agar trafik baliknya juga bisa melewati interface dimana trafik itu masuk

/ip firewall mangle
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether1 new-connection-mark=con-from-isp1 passthrough=yes comment=”trafik dari isp1”
add action=mark-connection chain=prerouting connection-mark=no-mark in-interface=ether2 new-connection-mark=con-from-isp2 passthrough=yes comment=”trafik dari isp2”

Umumnya, sebuah ISP akan membatasi akses DNS servernya dari IP yang hanya dikenalnya, jadi jika anda menggunakan DNS dari salah satu ISP anda, anda harus menambahkan mangle agar trafik DNS tersebut melalui gateway ISP yang bersangkutan bukan melalui gateway ISP lainnya. Disini kami berikan mangle DNS ISP1 yang melalui gateway ISP1. Jika anda menggunakan publik DNS independent, seperti opendns, anda tidak memerlukan mangle dibawah ini.

/ip firewall mangle
add action=mark-connection chain=output comment=dns dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=tcp comment=”trafik DNS citra.net.id”
add action=mark-connection chain=output dst-address=202.65.112.21 dst-port=53 new-connection-mark=dns passthrough=yes protocol=udp
add action=mark-routing chain=output connection-mark=dns new-routing-mark=route-to-isp1 passthrough=no

Karena kita menggunakan webproxy pada router, maka trafik yang perlu kita loadbalance ada 2 jenis. Yang pertama adalah trafik dari client menuju internet (non HTTP), dan trafik dari webproxy menuju internet. Agar lebih terstruktur dan mudah dalam pembacaannya, kita akan menggunakan custom-chain sebagai berikut :

/ip firewall mangle
add action=jump chain=prerouting comment=”lompat ke client-lb” connection-mark=no-mark in-interface=wlan2 jump-target=client-lb
add action=jump chain=output comment=”lompat ke lb-proxy” connection-mark=no-mark out-interface=!wlan2 jump-target=lb-proxy

Pada mangle diatas, untuk trafik loadbalance client pastikan parameter in-interface adalah interface yang terhubung dengan client, dan untuk trafik loadbalance webproxy, kita menggunakan chain output dengan parameter out-interface yang bukan terhubung ke interface client. Setelah custom chain untuk loadbalancing dibuat, kita bisa membuat mangle di custom chain tersebut sebagai berikut

/ip firewall mangle
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal loadbalancing klien”
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=client-lb dst-address-type=!local new-connection-mark=to-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=client-lb comment=”akhir dari loadbalancing”

/ip firewall mangle
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/0 comment=”awal load balancing proxy”
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp1 passthrough=yes per-connection-classifier=both-addresses:3/1
add action=mark-connection chain=lb-proxy dst-address-type=!local new-connection-mark=con-from-isp2 passthrough=yes per-connection-classifier=both-addresses:3/2
add action=return chain=lb-proxy comment=”akhir dari loadbalancing”

Untuk contoh diatas, pada loadbalancing client dan webproxy menggunakan parameter pemisahan trafik pcc yang sama, yaitu both-address, sehingga router akan mengingat-ingat berdasarkan src-address dan dst-address dari sebuah koneksi. Karena trafik ISP kita yang berbeda (512kbps dan 256kbps), kita membagi beban trafiknya menjadi 3 bagian. 2 bagian pertama akan melewati gateway ISP1, dan 1 bagian terakhir akan melewati gateway ISP2. Jika masing-masing trafik dari client dan proxy sudah ditandai, langkah berikutnya kita tinggal membuat mangle mark-route yang akan digunakan dalam proses routing nantinya

/ip firewall mangle
add action=jump chain=prerouting comment=”marking route client” connection-mark=!no-mark in-interface=wlan2 jump-target=route-client
add action=mark-routing chain=route-client connection-mark=to-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=to-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 passthrough=no
add action=mark-routing chain=route-client connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 passthrough=no
add action=return chain=route-client disabled=no

/ip firewall mangle
add action=mark-routing chain=output comment=”marking route proxy” connection-mark=con-from-isp1 new-routing-mark=route-to-isp1 out-interface=!wlan2 passthrough=no
add action=mark-routing chain=output connection-mark=con-from-isp2 new-routing-mark=route-to-isp2 out-interface=!wlan2 passthrough=no

Pengaturan Routing

Pengaturan mangle diatas tidak akan berguna jika anda belum membuat routing berdasar mark-route yang sudah kita buat. Disini kita juga akan membuat routing backup, sehingga apabila sebuah gateway terputus, maka semua koneksi akan melewati gateway yang masing terhubung

/ip route
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp1 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp1 distance=2
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.102.1 routing-mark=route-to-isp2 distance=1
add check-gateway=ping dst-address=0.0.0.0/0 gateway=192.168.101.1 routing-mark=route-to-isp2 distance=2

Pengujian

Dari hasil pengujian kami, didapatkan sebagai berikut

 

Dari gambar terlihat, bahwa hanya dengan melakukan 1 file download (1 koneksi), kita hanya mendapatkan speed 56kBps (448kbps) karena pada saat itu melewati gateway ISP1, sedangkan jika kita mendownload file (membuka koneksi baru) lagi pada web lain, akan mendapatkan 30kBps (240kbps). Dari pengujian ini terlihat dapat disimpulkan bahwa

512kbps + 256kbps ≠ 768kbps

Catatan :

* Loadbalancing menggunakan teknik pcc ini akan berjalan efektif dan mendekati seimbang jika semakin banyak koneksi (dari client) yang terjadi.

* Gunakan ISP yang memiliki bandwith FIX bukan Share untuk mendapatkan hasil yang lebih optimal.

* Load Balance menggunakan PCC ini bukan selamanya dan sepenuhnya sebuah solusi yang pasti berhasil baik di semua jenis network, karena proses penyeimbangan dari traffic adalah berdasarkan logika probabilitas.

RB250GS sebagai Multi Fungsi Switch

LAN ?

Lan adalah sebuah jaringan area lokal yang didefinisikan dan dinaungi oleh alamat network dan alamat broadcast yang sama.
Perlu Anda ingat juga bahwa pada perangkat Router akan menghentikan traffic broadcast apapun itu protocolnya, tetapi pada switch akan secara otomatis akan meneruskannya.

VLAN ?

VLAN adalah Virtual LAN yaitu sebuah jaringan LAN yang secara virtual dibuat di sebuah switch. Pada switch standard biasanya akan meneruskan traffic dari satu port ke semua port yang lain ketika ada traffic dengan domain broadcast yang sama melewati port tersebut.
Untuk switch yang khusus, mereka mampu untuk membuat beberapa LAN yang berbeda dengan id yang berbeda di tiap portnya, dan hanya akan meneruskan traffic ke port-port yang memiliki id yang sama.
Switch type khusus ini sebenarnya sudah secara otomatis memasang VLAN di dalamnya (vlan id = 1) yang beranggotakan semua port yang ada.

Mengapa VLAN dibutuhkan ?

Menjadi Sangat penting juga VLAN ini digunakan, yaitu ketika network Anda menjadi semakin besar skalanya dan traffic broadcast menjadi beban di seluruh network Anda.
Beban terlalu besar yang disebabkan oleh traffic broadcast ini bisa menyebabkan network Anda jatuh dan tidak se-responsif sebelumnya.

Kapan VLAN perlu diimplementasikan ?

Anda memerlukan VLAN ketika kondisi jaringan Anda :

  • Memiliki lebih dari 200 node perangkat di dalam jaringan Anda
  • Banyak terjadi traffic broadcast di jaringan Anda
  • Anda ingin membagi beberapa user Anda menjadi group-group tersendiri untuk meningkatkan keamanan
  • Mengurangi traffic broadcast yang banyak disebabkan oleh serangan virus dan program pengganggu lain yang akan memporak porandakan jaringan Anda.
  • Atau Anda hanya ingin membuat beberapa virtual switch dari switch yang sudah ada

Mengapa tidak menggunakan satu subnet saja ?

Pada perkembangan jaringan Anda, bisa saja membutuhkan perlakukan yang berbeda (VOIP network, server network, local network, Gateway yang berbeda) tetapi masih berada di dalam infrastruktur dan lokasi yang sama.
Atau bisa juga sebaliknya, Anda memiliki beberapa perangkat yang berlainan infrastruktur dan lokasi tetapi masih berada dalam satu segmen network yang sama (infrastructure sharing).

Bagaimana perangkat yang berbeda VLAN bisa berkomunikasi ?

Pada perangkat yang berbeda vlan akan dapat berkomunikasi satu sama lain melalui router (routing protocol). Sama seperti halnya beberapa subnet yang berbeda berkomunikasi satu sama lain dengan bantuan router.

RB250GS ?

Salah satu produk Mikrotik terbaru yaitu RB250GS adalah termasuk didalam switch khusus yang bisa mengimplementasikan VLAN di setiap portnya. Dan mungkin switch manageable terkecil dan termurah yang pernah dibuat. Selain membuat Jaringan Anda lebih terorganisasi dengan baik mungkin switch kecil ini bisa menjadi sarana hemat Anda untuk mengenal dan mengimplementasikan VLAN di jaringan Anda.

Implementasi Dasar VLAN menggunakan RB250GS

Pada bagan di bawah ini adalah bagan jaringan untuk contoh implememtasi VLAN yang bisa dilakukan oleh produk router mikrotik dan tentunya dipadukan dengan switch mikrotik RB250GS.

Pada Bagan Network di atas sudah digambarkan se-sederhana mungkin dengan dilengkapi keterangan jalur dan warna yang berbeda untuk membedakan fungsi dan tugasnya.

Jalur Internet akan masuk ke dalam router mikrotik Anda melalui interface Ether1 dan akan didistribusikan kembali ke jaringan Local melalui Interface Ether2.

Pada Ether2 di router terdapat 2 VLAN yaitu VLAN2 (untuk melambangkan segmen network 1) dan VLAN3 (untuk melambangkan segmen network 2). Kedua informasi VLAN ini akan diteruskan ke switch RB250GS dengan menghubungkan Ether2 dari router ke Ether1-Switch.

Pada switch RB250GS segmen network 1 dan network 2 akan didistribusikan ke interface yang berbeda, yaitu network 1 distribusi ke Ether2-Switch sedangkan segmen network 2 akan didistribusikan ke Ether3-Switch.

Dengan konfigurasi seperti ini, semua Perangkat apapun yang tekoneksi ke Ether2-Switch (PC, Printer) akan memiliki subnet yang berbeda dengan perangakat (Server, Voip phone, IP Cam) yang terhubung ke Ether3-Switch.

Semua perangkat yang terhubung di kedua port switch ini harus menggunakan routing terlebih dahulu di router untuk berkomunikasi satu sama lain.

Trunk Link ?

Trunk link adalah sebuah komunikasi antara Switch dengan Switch atau bisa juga antara Switch dengan Router, yang membawa informasi beberapa VLAN (VLAN ID) yang bebeda diantara kedua perangkat tersebut. Pada Ether2 di router akan menyeberangkan informasi VLAN2 (VLAN ID=2) dan VLAN3 (VLAN ID=3) ke Ether1-Switch.

Pada dua gambar capture di atas adalah contoh pembuatan Trunk Interface di router (Interface master Ether2).
IP Address yang berbeda segmen sudah bisa dipasang di kedua Vlan interface.

RB250GS Config

Langkah selanjutnya adalah melakukan konfigurasi Switch manageable RB250GS, Untuk konfigurasi RB250GS dilakukan menggunakan Web browser dan gunakan Username=admin password=[kosong].
Direkomendasikan untuk langkah awal adalah mengubah ip default di switch dari 192.168.88.1 menjadi ip yang lain untuk menghindari terjadinya conflict dengan ip default router.

Vlan Table

Langkah selanjutnya adalah untuk mendaftarkan Vlan ID yang akan didistribusikan ke switch. Port1-Switch akan bertindak sebagai trunk port sehingga Vlan2 dan Vlan3 akan diforward di port ini. Sedangkan pada Port2-Switch akan hanya memforward vlan 2 dan Port3-Switch hanya akan memforward vlan 3.

Ilustrasi di atas dalah contoh config untuk Membuat Vlan table di RB250GS.

Pada switch manageable dikenal adanya Ingress Filtering dan Egress Filtering untuk mengatur bagaimana switch memperlakukan traffic yang datang dan meninggalkan port tersebut.
Ingress filtering adalah policy dari switch untuk mengatur traffic yang datang, sedangkan Egress filter untuk mengatur traffic yang keluar dari port tersebut.

Pada ilustrasi di atas menunjukkan pada Ingress port di switch RB250GS pada port 1,2 dan 3 akan diperlakukan vlan forward policy (Vlan Mode = Enabled), yang disesuaikan dengan konfigurasi di Vlan table.
Pada setting Egress filter policy akan menunjukkan fungsi dari port itu sendiri. Contohnya pada Port1-Switch karena bertindak sebagai Trunk maka policy yang digunakan adalah “add if missing“, sedangkan pada Port2 dan Port3-Switch akan bertindak sebagai Access port maka akan menggunakan policy “always strip“.

Cara kerjanya adalah sebagai berikut :

  • Traffic yang datang dari Port1-Switch adalah traffic yang memiliki vlan header dan Vlan ID yang akan diterima dan diteruskan adalah Vlan dengan ID 2 dan 3 (sesuai dengan Vlan table).
  • Kita ambil contoh Ketika ada traffic dari Router dengan vlan ID=2 maka akan diteruskan ke Port2-Switch (sesuai vlan table). Dan pada saat traffic meninggalkan port2-switch, vlan header akan dihilangkan (egress policy di port2-switch yaitu “always strip”).
  • Berbeda perlakuannya Pada traffic balik atau traffic balas yang datang dari port2-Switch menuju ke router maka akan diforward ke port1-switch, dan akan ditambahkan vlan header sesuai dengan default vlan id yang ada di port2-switch pada saat traffic meninggalkan port1-swith (egress port policy add if missing).

Kombinasi dengan Switch Manageable lain

Ada kondisi tertentu dimana Anda sudah mengimplementasikan VLAN di network Anda, dan kebetulan memang sudah memiiki beberapa vlan yang ada di switch manageable Anda. Maka jika Anda ingin menggabungkan atau mengkombinasi antara switch manageable yang sudah ada dengan switch RB250GS, maka konfigurasi di RB250GS tidak akan jauh berbeda.
Kuncinya ada di vlan ID yang sudah ada sebelumnya tetap harus dideklarasikan di vlan table RB250GS, dan port trunk tetap harus dibuat di salah satu port. Port trunk ini akan menjadi penjembatan antara Swich manageable Anda dengan RB250GS ini sendiri.

Pada bagan diatas, merupakan contoh bagan pengguaan RB250GS yang dikombinasikan dengan Switch manageable yang lain.

Trunk port harus dibuat di switch manageable yaitu untuk menghubungkan antara router ke switch manageable dan satu lagi trunk port untuk menghubungkan switch manageable tersebut ke switch RB250GS.

Setting Mikrotik Wireless Bridge

Sering kali, kita ingin menggunakan Mikrotik Wireless untuk solusi point to point dengan mode jaringan bridge (bukan routing). Namun, Mikrotik RouterOS sendiri didesain bekerja dengan sangat baik pada mode routing. Kita perlu melakukan beberapa hal supaya link wireless kita bisa bekerja untuk mode bridge.

Mode bridge memungkinkan network yang satu tergabung dengan network di sisi satunya secara transparan, tanpa perlu melalui routing, sehingga mesin yang ada di network yang satu bisa memiliki IP Address yang berada dalam 1 subnet yang sama dengan sisi lainnya.

Namun, jika jaringan wireless kita sudah cukup besar, mode bridge ini akan membuat traffic wireless meningkat, mengingat akan ada banyak traffic broadcast dari network yang satu ke network lainnya. Untuk jaringan yang sudah cukup besar, saya menyarankan penggunaan mode routing.

Berikut ini adalah diagram network yang akan kita set.

Konfigurasi Pada Access Point

1. Buatlah sebuah interface bridge yang baru, berilah nama bridge1

2. Masukkan ethernet ke dalam interface bridge

3. Masukkan IP Address pada interface bridge1

4. Selanjutnya adalah setting wireless interface. Kliklah pada menu Wireless (1), pilihlah tab interface (2) lalu double click pada nama interface wireless yang akan digunakan (3). Pilihlah mode AP-bridge (4), tentukanlah ssid (5), band 2.4GHz-B/G (6), dan frekuensi yang akan digunakan (7). Jangan lupa mengaktifkan default authenticated (8) dan default forward (9). Lalu aktifkankanlah interface wireless (10) dan klik OK (11).

5. Berikutnya adalah konfigurasi WDS pada wireless interface yang digunakan. Bukalah kembali konfigurasi wireless seperti langkah di atas, pilihlah tab WDS (1). Tentukanlah WDS Mode dynamic (2) dan pilihlah bridge interface untuk WDS ini (3). Lalu tekan tombol OK.

6. Langkah selanjutnya adalah menambahkan virtual interface WDS. Tambahkan interface WDS baru seperti pada gambar, lalu pilihlah interface wireless yang kita gunakan untuk WDS ini. Lalu tekan OK.

7. Jika WDS telah ditambahkan, maka akan tampak interface WDS baru seperti pada gambar di bawah.

Konfigurasi pada Wireless Station

Konfigurasi pada wireless station hampir sama dengan langkah-langkah di atas, kecuali pada langkah memasukkan IP Address dan konfigurasi wirelessnya. Pada konfigurasi station, mode yang digunakan adalah station-wds, frekuensi tidak perlu ditentukan, namun harus menentukan scan-list di mana frekuensi pada access point masuk dalam scan list ini. Misalnya pada access point kita menentukan frekuensi 2412, maka tuliskanlah scan-list 2400-2500.


Pengecekan link

Jika link wireless yang kita buat sudah bekerja dengan baik, maka pada menu wireless, akan muncul status R (lihat gambar di bawah).

Selain itu, mac-address dari wireless yang terkoneksi juga bisa dilihat pada jendela registration (lihat gambar di bawah).


Konfigurasi keamanan jaringan wireless

Pada Mikrotik, cara paling mudah untuk menjaga keamanan jaringan adalah dengan mendaftarkan mac-address wireless pasangan pada access list. Hal ini harus dilakukan pada sisi access point maupun pada sisi client. Jika penginputan access-list telah dilakukan, maka matikanlah fitur default authenticated pada wireless, maka wireless lain yang mac addressnya tidak terdaftar tidak akan bisa terkoneksi ke jaringan kita.

Jika kita menginginkan fitur keamanan yang lebih baik, kita juga bisa menggunakan enkripsi baik WEP maupun WPA.

Garuda OS : Sistem Operasi Lokal untuk Kebangkitan Nasional (TI) Indonesia

Diooda Blog | http://diooda.blogspot.com/ | Garuda OS : Sistem Operasi Lokal untuk Kebangkitan Nasional (TI) Indonesia

Selama puluhan tahun, Indonesia sudah sangat terikat dan tergantung pada software bajakan. Kemandirian (TI) Indonesia tidak akan pernah terwujud selama kita tidak berani bangkit untuk melakukan perubahan. Agar bisa mandiri, kita harus mulai berani untuk melepaskan diri dari belenggu software bajakan dan beralih ke software legal dari pengembang lokal, seperti GARUDA.

Hari Kebangkitan Nasional 2011 ini merupakan saat yang tepat untuk kita mulai belajar mandiri dan bangkit – khususnya di bidang TI – dengan mulai beralih dari menggunakan sistem operasi bajakan ke GARUDA.

Apa yang bisa kita lakukan untuk menuju kemandirian (TI) Indonesia ???

  1. Kemandirian Software. Beralih dari software bajakan ke software legal kreasi lokal, dalam hal ini kita bisa mendukung penggunaan sistem operasi lokal GARUDA sebagai pengganti OS bajakan.
  2. Kemandirian Hardware. Menghindari pengadaan hardware yang tidak / belum mendukung software lokal. Jika Anda sebagai vendor hardware, mulailah untuk mendukung software lokal.
  3. Kemandirian Game. Menghindari bermain game (online) yang tidak / belum mendukung software lokal. Jika Anda vendor game online, mulailah untuk mendukung software lokal.
  4. Kemandirian Dokumen. Beralih menggunakan dokumen dengan format SNI (Standard Nasional Indonesia), yaitu Open Document Format (ODF) yang merupakan default format dokumen GARUDA.

 

GARUDA OS

Versi : GARUDA 1.1.5
Tanggal Rilis : 20-5-2011
Pengguna : Pemula s/d Mahir
Ukuran : 3.6 GB

TENTANG GARUDA :
GARUDA adalah sistem operasi (OS) legal berbasis sistem terbuka (Open Source) kreasi dari pengembang lokal. GARUDA menggunakan desktop modern yang menawan dan sangat mudah dipergunakan, bahkan oleh para pengguna yang sudah terbiasa dengan Windows.

GARUDA mendukung penggunaan dokumen format SNI (Standar Nasional Indonesia). GARUDA juga sangat aman dari gangguan virus komputer, stabilitasnya tinggi, disertai dukungan bahasa Indonesia dan dilengkapi dengan banyak program dari berbagai macam kategori.

GARUDA bisa diperoleh secara bebas tanpa harus mengeluarkan biaya untuk pembelian lisensi, namun tetap mengutamakan kualitas.

VIDEO GARUDA :
Video klip Desktop Garuda, Mode Netbook Garuda, Menu Program Aplikasi serta Program Perkantoran Garuda bisa dilihat disini.

FITUR GARUDA :

  • Inti (kernel) sistem operasi : 2.6.38.7
  • Desktop : KDE 4.6.3
  • Dukungan driver VGA (Nvidia, ATI, Intel, dll)
  • Dukungan Wireless untuk berbagai perangkat jaringan
  • Dukungan perangkat printer lokal ataupun jaringan
  • Dukungan banyak format populer multimedia (flv, mp4, avi, mov, mpg, mp3, wma, wav, ogg, dll …)
  • Dukungan bahasa Indonesia dan bahasa Inggris serta lebih dari 60 bahasa dunia lainnya (Jepang, Arab, Korea, India, Cina, dll…)
  • Dukungan untuk instalasi berbagai macam program aplikasi dan game (online) berbasis Windows
  • Dukungan untuk berbagai macam dokumen dari program populer berbasis Windows (seperti Photoshop, CorelDraw, MS Office, AutoCAD, dll)
  • NEW : Dukungan Font Aksara Indonesia (video).
  • NEW : Dukungan ratusan Font Google Web (video).

KEBUTUHAN PERANGKAT KERAS :

  • Processor : Intel Atom; Intel atau AMD sekelas Pentium IV atau lebih
  • Memory : RAM minimum 512 MB, rekomendasi 1 GB.
  • Hard disk : minimum 8 GB, rekomendasi 20 GB atau lebih jika ingin menginstal program lain
  • Video card : nVidia, ATI, Intel, SiS, Matrox, VIA
  • Sound card : Sound Blaster, kartu AC97 atau HDA

PROGRAM APLIKASI :
Perkantoran :

  • LibreOffice 3.3 – disertai kumpulan ribuan clipart, kompatibel dengan MS Office dan mendukung format dokumen SNI (Standar Nasional Indonesia)
  • Scribus – desktop publishing (pengganti Adobe InDesign, Page Maker)
  • Dia – diagram / flowchart (pengganti MS Visio)
  • Planner – manajemen proyek (pengganti MS Project)
  • GnuCash, KMyMoney – program keuangan (pengganti MYOB, MS Money, Quicken)
  • Kontact – Personal Information Manager / PIM
  • Okular, FBReader – universal document viewer
  • dan lain-lain …

Internet :

  • Mozilla Firefox 4.0.1, Chromium, Opera – web browser (pengganti Internet Explorer)
  • Mozilla Thunderbird – program email (pengganti MS Outlook)
  • FileZilla – upload download / FTP
  • kTorrent – program bittorrent
  • DropBox – Online Storage Program (free 2 Gb)
  • Choqok, Qwit, Twitux, Pino – aplikasi microblogging
  • Google Earth – penjelajah dunia
  • Skype – video conference / VOIP
  • Gyachi, Pidgin – Internet messenger
  • xChat – program chatting / IRC
  • Kompozer, Bluefish – web / html editor (pengganti Dreamweaver)
  • Miro – Internet TV
  • dan lain-lain …

Multimedia :

  • GIMP – editor gambar bitmap (pengganti Adobe Photoshop)
  • Inkscape – editor gambar vektor (pengganti CorelDraw)
  • Blender – Animasi 3D
  • Synfig, Pencil – Animasi 2D
  • XBMC – multimedia studio
  • kSnapshot – penangkap gambar layar
  • Digikam – pengelola foto digital
  • Gwenview – Photo Viewing Client
  • Amarok – audio player + Internet radio
  • Kaffeine – video / movie player
  • TVtime – television viewer
  • Audacity – audio editor
  • Cinelerra, Avidemux – video editor
  • dan lain-lain …

Edukasi :

  • Matematika – aljabar, geometri, plotter, pecahan
  • Bahasa – Inggris, Jepang, permainan bahasa
  • Geografi – atlas dunia, planetarium, kuis
  • Kimia – tabel periodik
  • Logika Pemrograman

Administrasi Sistem :

  • DrakConf – Computer Control Center
  • Synaptic – Software Package Manager
  • Samba – Windows sharing file
  • Team Viewer – remote desktop & online meeting
  • Bleachbit – pembersih sistem
  • Back in Time – backup restore sistem
  • dan lain-lain …

Program Bantu :

  • Ark – program kompres file (pengganti Winzip, WinRar)
  • K3b – pembakar CD/DVD (pengganti Nero)
  • Dolphin – file manager
  • Cairo Dock – Mac OS menu dock
  • Compiz Fusion + Emerald
  • Emulator DOS + Windows
  • dan lain-lain …

Game :

  • 3D Game Maker
  • Mahjong, Tetris, Rubik, Billiard, Pinball, BlockOut, Sudoku, Reversi
  • Solitaire, Heart, Domino, Poker, Backgammon, Chess, Scrabble
  • Frozen Bubble, Flight Simulator, Tron, Karaoke
  • City Simulation, Fighter, Doom, Racing, Tremulous FPS
  • DJL, Play on Linux, Autodownloader – game manager / downloader
  • dan lain-lain ….

Dan diluar program-program yang sudah terinstal diatas, masih ada lebih dari 10.000 program tambahan dalam berbagai kategori yang tersedia di repository (pustaka program) Synaptic.